Huawei et carte SD comme périphérique de stockage de masse

Accueil Forums Forum d’aide High Tech, Smartphone, Tablette, Android… Huawei et carte SD comme périphérique de stockage de masse

  • Ce sujet contient 13 réponses, 2 participants et a été mis à jour pour la dernière fois par Patou, le il y a 2 années et 6 mois.
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #3269
    membre anonyme
    Participant

    Bonjour à tous,

    J’ai acheté récemment un Huawei P9 lite, et il semble que pour avoir accès aux fichiers il faille nécessairement installer leur appli « Hi suite ».

    Existe-t-il un moyen de contourner cette installation (que je trouve au passage excessivement intrusive !) ? Je souhaiterais simplement pouvoir avoir accès à ma carte SD comme périphérique de stockage de masse.

    Je suis sur que cable et téléphone fonctionnent puisqu’en me branchant en USB, je vois dans mes périphériques le fichier d’install’ de leur Hi suite … c’est que le reste ne doit pas être loin ?!

    Merci à tous pour votre aide,

    Bencho

    #3991
    bencho
    Invité

    Remarque : dans les options pour développeurs, rubrique « selectionner la configuration USB », on peut choisir entre MTP, PTP, USB ethernet, et source audio … autant vous dire que cela ne m’avance pas tellement…

    D’autant que sur http://supertos.free.fr/supertos.php?page=1164 j’ai trouvé une confirmation que la carte SD était désactivée (et inaccessible) par défaut le temps de la connexion USB…

    Merci par avance pour tous vos conseils !!

    Bencho

    #3992
    David Jovanovic
    Maître des clés

    Bonjour,

    Le stockage de masse n’est plus géré dans les versions Android  4 (ou 5). C’est remplacé par les technologies que tu as cité, MTP (transfert de fichiers) , PTP (transfert d’images uniquement) entre autres.

    En choisissant Périphérique MTP, tu auras accès au contenu de ton téléphone et ta carte SD.

    #3993
    Bencho
    Invité

    Je test ca de suite. Merci beaucoup !

    #3994
    Bencho
    Invité

    Malheureusement le mode MTP était le mode par défaut… et ça ne marche pas. Dans mon poste de travail, je n’accède qu’à un répertoire type « lecteur de CD », et en l’explorant je tombe sur l’install du logiciel « Hi suite », mais évidemment pas le contenu de ma carte SD…

    J’ai essayé d’autres modes sans plus de succès…

    #3995
    David Jovanovic
    Maître des clés

    Dans un premier temps, assure toi que dans le mode développeur, le mode « Debug USB » soit bien désactivé.

    Ensuite lorsque tu branche ton Huawei à ton ordi, tu devrais avoir une notification sur ton téléphone te proposant plusieurs choix de connection. A partir de cette notification, essaie de passer à PTP, de voir ce qu’il se passe, puis de repasser sur MTP.

    #3996
    Bencho
    Invité

    Le mode debogage était bien désactivé.
    Ensuite, quand je me connecte sur mon téléphone je peux choisir le type de connexion «photo» ou «fichier» ce qui doit correspondre respectivement à PTP et MTP, mais sans grande différence sur le résultat. Mon ordinateur ne reconnait toujours que le lecteur CD virtuel avec l’install de l’appli hi-suite.

    J’ai l’impression d’avoir acheté un appareil android avec les contraintes d’un apple ^^ . On doit pourtant pouvoir faire sans leur logiciel !
    En tout cas merci pour ton aide !!

    #3997
    David Jovanovic
    Maître des clés

    Ok, essaie de le brancher ton téléphone en MTP, puis tu fais un clic droit sur le menu Démarrer puis « Gestionnaire de périphérique ». Ensuite, dans la liste, est-ce que tu vois un périphérique avec un point d’exclamation jaune devant ? Ou quelque chose qui s’appelerait Huawei P9 …

    #3998
    Bencho
    Invité

    Bonjour Vitch,

    En effet, le périphérique « Huawei » (type « lecteur optique ») apparait bien dans le gestionnaire de périphérique avec un triangle jaune « ! » (« nécessite un dépannage »).

    Par contre, dès que j’essaye de modifier les paramètres (notamment dans l’onglet matériel / stockage de masse), je me heurte à une barrière car je ne suis pas admin. Je ré-essaye ça sur mon pc perso ce weekend, et je te tiens au courant.

     

    #3999
    David Jovanovic
    Maître des clés

    Ok, il semblerait donc qu’il y a ait un problème de pilote  ;). Tu pourras également essayer cette manipulation pour réinstaller le drivers :

    https://www.lecoindunet.com/comment/7600#comment-7600 :

    1. Connecte ton téléphone à ton ordinateur avec ton câble USB.
    2. Ouvres ton Gestionnaire de périphériques.
    3. Cliques sur le menu Affichage et coche Afficher les périphériques cachés.
    4. Dans la liste, tu dois avoir un élément Périphérique inconnu. Fais un clic droit dessus puis Mettre à jour le pilote.
    5. Choisis Rechercher un pilote sur mon ordinateur.
    6. Puis Choisir parmi une liste de pilotes de périphériques sur mon ordinateur.
    7. Cliques sur Périphérique USB MTP dans la liste puis sur Suivant.
    8. Windows devrait t’installer le pilote puis t’afficher un nouveau périphérique MTP.
    #4263
    bidule truc
    Invité

    2 heures à galérer sur ce problème de CD virtuel qui bloque l’accès au stockage du mobile

    Aller dans
    PARAMETRES
    PARAMETRES AVANCES
    SECURITE
    Utilisation HDB
    à décocher car quand c’est coché, cela propose un CD virtuel avec l’exe pour télécharger la dernière version de HiSuite

    Merci Bencho car je me suis senti moins seul quand t’as décrit mon problème
    Sans doute une réponse trop tardive pour toi…
    Mais peut être que d’autres en feront quelque chose

    Chalut à tous et merci pour le forum

    #4264
    bidule truc
    Invité

    Désolé pour la mise en texte au dessus

    Paramètres ->> Paramètres avancés ->> Sécurité
    Décocher l’option -> Utilisation HDB (dans le le chapitre Suite PC HiSuite)

    Je crois que c’est plus clair ainsi mis en forme

    A+

    #4272
    bencho
    Invité

    Hey, Merci pour ton retour en tout cas !
    Je vais tester ça rapidement. De mon coté, j’avais surtout constaté que le pb ne survenait qu’au boulot, donc sur Windows. Par contre ça fonctionne tout seul et sans manip sous Linux (Ubuntu).

    Bonne journée à tous, et je vous redis quand j’ai testé ça de mon coté !

    #4281
    Patou
    Invité

    Salut,
    J’avais le même pb. Je l’ai résolu en réinstallant le pilote de mon téléphone sur le PC (–> panneau de config, gestionnaire de périphérique)
    Bon courage.

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.
0 Partages
Tweetez
Partagez
Partagez